summaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-at91
diff options
context:
space:
mode:
authorClaudiu Beznea <claudiu.beznea@microchip.com>2021-10-11 11:47:24 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2021-10-24 18:52:21 +0200
commit60f52f9b0d9dba7bcaec0be110178f0e3eadceb9 (patch)
treea52d956c8ce32c812d68e464eb88274e86a58f73 /package/boot/uboot-at91
parent8b7e577f76897ee44bc00a2303cbcae2a52b5ebf (diff)
downloadopenwrt-60f52f9b0d9dba7bcaec0be110178f0e3eadceb9.tar.gz
openwrt-60f52f9b0d9dba7bcaec0be110178f0e3eadceb9.tar.bz2
openwrt-60f52f9b0d9dba7bcaec0be110178f0e3eadceb9.zip
at91: add support for sama5d27-wlsom1-ek board
Add support for SAMA5D27 WLSOM1-EK board. Hardware: - SIP: SAMA5D27C-LD2G-CU including SAMA5D27 MPU and 2Gbit LPDDR2-SDRAM - MMC: one standard SD card interface - Flash: 64 Mb serial quad I/O flash memory (SST26VF064BEUIT-104I/MF) with embedded EUI-48 and EUI-64 MAC addresses - USB: one USB device, one USB host one HSIC interface - Ethernet: 1x10/100Mbps port - WiFi/BT: IEEE 802.11 b/g/n Wi-Fi plus Bluetooth (Wi-Fi/BT) module (ATWILC3000-MR110UA) - Crypto: one ATECC608B-TNGTLS secure element - Video: one LCD RGB 18-bit interface, one ISC 12-bit camera interface - Debug port: one JTAG interface, one UART interface, one WILC UART interface - Leds: one RGB LED - Buttons: start, reset, wakeup, user buttons - Expansion: one tamper connector, one mikrobus interface, 2 XPRO PTC connector - Power managament: PMIC (MCP16502) Flashing: - follow procedure at [1] [1] https://www.linux4sam.org/bin/view/Linux4SAM/Sama5d27WLSom1EKMainPage#Create_a_SD_card_with_the_demo Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
Diffstat (limited to 'package/boot/uboot-at91')
-rw-r--r--package/boot/uboot-at91/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 822d71f796..3262da4cbe 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -107,6 +107,18 @@ define U-Boot/sama5d27_som1_ek_qspiflash
BUILD_DEVICES:=microchip_sama5d27-som1-ek
endef
+define U-Boot/sama5d27_wlsom1_ek_mmc
+ NAME:=SAMA5D27 WLSOM1 Ek (SDCard)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=microchip_sama5d27-wlsom1-ek
+endef
+
+define U-Boot/sama5d27_wlsom1_ek_qspiflash
+ NAME:=SAMA5D27 WLSOM1 Ek (QSPI Flash)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=microchip_sama5d27-wlsom1-ek
+endef
+
define U-Boot/sama5d2_ptc_ek_nandflash
NAME:=SAMA5D2 PTC Ek (Nand Flash)
BUILD_SUBTARGET:=sama5
@@ -133,6 +145,8 @@ UBOOT_TARGETS := \
sama5d4_xplained_nandflash\
sama5d27_som1_ek_mmc1 \
sama5d27_som1_ek_qspiflash \
+ sama5d27_wlsom1_ek_mmc \
+ sama5d27_wlsom1_ek_qspiflash \
sama5d2_ptc_ek_nandflash \
sama5d2_ptc_ek_mmc