summaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-at91
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2017-09-13 11:51:21 -0700
committerJohn Crispin <john@phrozen.org>2017-09-20 09:01:31 +0200
commitdacab6472d8dcf4a4e9719eee5cdc87dc8a81513 (patch)
tree3eabc91ab20331ce63dc4fb7e70bae0729a4382a /package/boot/uboot-at91
parent8f1764b98a2251c5780455ac131b38ecf9a53bca (diff)
downloadopenwrt-dacab6472d8dcf4a4e9719eee5cdc87dc8a81513.tar.gz
openwrt-dacab6472d8dcf4a4e9719eee5cdc87dc8a81513.tar.bz2
openwrt-dacab6472d8dcf4a4e9719eee5cdc87dc8a81513.zip
uboot-at91: Add support for SAMA5D2 Xplained board
Add support for SAMA5D2 Xplained board and options to select & build u-boot configs for different media storage. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'package/boot/uboot-at91')
-rw-r--r--package/boot/uboot-at91/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 2c95377b0f..e2d3ed0322 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -42,11 +42,26 @@ define uboot/sama5d3_xplained_mmc
BUILD_DEVICES:=at91-sama5d3_xplained
endef
+define uboot/sama5d2_xplained_spiflash
+ TITLE:=U-Boot for the SAMA5D2 Xplained board (SPI Flash)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=at91-sama5d2_xplained
+endef
+
+define uboot/sama5d2_xplained_mmc
+ TITLE:=U-Boot for the SAMA5D2 Xplained board (SDcard/EMMC)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=at91-sama5d2_xplained
+endef
+
UBOOT_TARGETS := \
at91sam9m10g45ek_nandflash \
at91sam9x5ek_nandflash \
sama5d3_xplained_nandflash \
- sama5d3_xplained_mmc
+ sama5d3_xplained_mmc \
+ sama5d2_xplained_mmc \
+ sama5d2_xplained_spiflash
+
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \