summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/fs.mk
diff options
context:
space:
mode:
authorJohn Thomson <git@johnthomson.fastmail.com.au>2022-12-24 22:57:34 +1000
committerHauke Mehrtens <hauke@hauke-m.de>2023-05-18 16:52:05 +0200
commit507480a92c0bc8c26f8f0edeaf35719ea8089c11 (patch)
tree2696e6135744ab13cfbe75bf910a4d496af1a760 /package/kernel/linux/modules/fs.mk
parentb09a83808a3a4f6ff2ff0cf1f12fdc4193357896 (diff)
downloadopenwrt-507480a92c0bc8c26f8f0edeaf35719ea8089c11.tar.gz
openwrt-507480a92c0bc8c26f8f0edeaf35719ea8089c11.tar.bz2
openwrt-507480a92c0bc8c26f8f0edeaf35719ea8089c11.zip
kernel: modules: split smbfs-common from cifs
This kernel config symbol is a shared library used for both CIFS and the in-tree SMB_SERVER. Split it out into kmod-fs-smbfs-common from kmod-fs-cifs, and depend on it, so that later in-tree ksmbd may also depend on it. Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
Diffstat (limited to 'package/kernel/linux/modules/fs.mk')
-rw-r--r--package/kernel/linux/modules/fs.mk21
1 files changed, 18 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 77d8d6c98b..c3c56864b7 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -83,21 +83,36 @@ endef
$(eval $(call KernelPackage,fs-btrfs))
+define KernelPackage/fs-smbfs-common
+ SUBMENU:=$(FS_MENU)
+ TITLE:=SMBFS common dependencies support
+ HIDDEN:=1
+ KCONFIG:=CONFIG_SMBFS_COMMON
+ FILES:= \
+ $(LINUX_DIR)/fs/smbfs_common/cifs_arc4.ko \
+ $(LINUX_DIR)/fs/smbfs_common/cifs_md4.ko
+endef
+
+define KernelPackage/fs-smbfs-common/description
+ Kernel module dependency for CIFS or SMB_SERVER support
+endef
+
+$(eval $(call KernelPackage,fs-smbfs-common))
+
+
define KernelPackage/fs-cifs
SUBMENU:=$(FS_MENU)
TITLE:=CIFS support
KCONFIG:= \
- CONFIG_SMBFS_COMMON \
CONFIG_CIFS \
CONFIG_CIFS_DFS_UPCALL=n \
CONFIG_CIFS_UPCALL=n
FILES:= \
- $(LINUX_DIR)/fs/smbfs_common/cifs_arc4.ko \
- $(LINUX_DIR)/fs/smbfs_common/cifs_md4.ko \
$(LINUX_DIR)/fs/cifs/cifs.ko
AUTOLOAD:=$(call AutoLoad,30,cifs)
$(call AddDepends/nls)
DEPENDS+= \
+ +kmod-fs-smbfs-common \
+kmod-crypto-md5 \
+kmod-crypto-sha256 \
+kmod-crypto-sha512 \