summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/fs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/fs.mk')
-rw-r--r--package/kernel/linux/modules/fs.mk21
1 files changed, 18 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 77d8d6c98b..c3c56864b7 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -83,21 +83,36 @@ endef
$(eval $(call KernelPackage,fs-btrfs))
+define KernelPackage/fs-smbfs-common
+ SUBMENU:=$(FS_MENU)
+ TITLE:=SMBFS common dependencies support
+ HIDDEN:=1
+ KCONFIG:=CONFIG_SMBFS_COMMON
+ FILES:= \
+ $(LINUX_DIR)/fs/smbfs_common/cifs_arc4.ko \
+ $(LINUX_DIR)/fs/smbfs_common/cifs_md4.ko
+endef
+
+define KernelPackage/fs-smbfs-common/description
+ Kernel module dependency for CIFS or SMB_SERVER support
+endef
+
+$(eval $(call KernelPackage,fs-smbfs-common))
+
+
define KernelPackage/fs-cifs
SUBMENU:=$(FS_MENU)
TITLE:=CIFS support
KCONFIG:= \
- CONFIG_SMBFS_COMMON \
CONFIG_CIFS \
CONFIG_CIFS_DFS_UPCALL=n \
CONFIG_CIFS_UPCALL=n
FILES:= \
- $(LINUX_DIR)/fs/smbfs_common/cifs_arc4.ko \
- $(LINUX_DIR)/fs/smbfs_common/cifs_md4.ko \
$(LINUX_DIR)/fs/cifs/cifs.ko
AUTOLOAD:=$(call AutoLoad,30,cifs)
$(call AddDepends/nls)
DEPENDS+= \
+ +kmod-fs-smbfs-common \
+kmod-crypto-md5 \
+kmod-crypto-sha256 \
+kmod-crypto-sha512 \