summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorLinus Walleij <linus.walleij@linaro.org>2023-10-12 10:42:19 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-10-20 13:27:48 +0200
commitf2bc4c1f1588430d992a2804dbc5cd2c250d914a (patch)
tree1257dc8ff9275a7938a327a24609d82720ef9bfa /package/kernel/linux/modules/other.mk
parent806b359bbc07cb21a41091f2c76ed682a02b55aa (diff)
downloadopenwrt-f2bc4c1f1588430d992a2804dbc5cd2c250d914a.tar.gz
openwrt-f2bc4c1f1588430d992a2804dbc5cd2c250d914a.tar.bz2
openwrt-f2bc4c1f1588430d992a2804dbc5cd2c250d914a.zip
kernel: Add kmod-rtc-r7301
To support the IXP42x platforms we need a kernel module for the Epson R7301 RTC so we can load it as an optional module. Signed-off-by: Linus Walleij <linus.walleij@linaro.org> Reviewed-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 2cd01d84d5..feee39602d 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -728,6 +728,21 @@ endef
$(eval $(call KernelPackage,rtc-pcf2127))
+define KernelPackage/rtc-r7301
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Epson RTC7301 support
+ DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+ KCONFIG:=CONFIG_RTC_DRV_R7301 \
+ CONFIG_RTC_CLASS=y
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-r7301.ko
+ AUTOLOAD:=$(call AutoProbe,rtc-r7301)
+endef
+
+define KernelPackage/rtc-r7301/description
+ Kernel module for Epson RTC7301 RTC chip
+endef
+
+$(eval $(call KernelPackage,rtc-r7301))
define KernelPackage/rtc-rs5c372a
SUBMENU:=$(OTHER_MENU)