summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorWeijie Gao <hackpascal@gmail.com>2024-01-06 15:17:17 +0800
committerRobert Marko <robimarko@gmail.com>2024-03-11 20:17:26 +0100
commitef523fdb075b2fd0cd96d1a209693f120ab7369c (patch)
treee18eef03fd81b606b85b2dd400955228e757b8b8 /package/kernel/linux
parentad2906b40573b35d01d5de636fd41edcc9b6a26d (diff)
downloadopenwrt-ef523fdb075b2fd0cd96d1a209693f120ab7369c.tar.gz
openwrt-ef523fdb075b2fd0cd96d1a209693f120ab7369c.tar.bz2
openwrt-ef523fdb075b2fd0cd96d1a209693f120ab7369c.zip
kernel: modules: usb: adapt for kernel 6.6
Adapt usb kmods for building under kernel 6.6: * Add kmod-phylink as dependency for usb-net-asix * Add kmod-net-selftests as dependency for usb-net-smsc95xx * Add kmod-iio-core as dependency for usb-hid-mcp2221 as ADC/DAC support was added since 6.2 which requires IIO. Signed-off-by: Weijie Gao <hackpascal@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/usb.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index f4a2113e17..7b680288b9 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1184,7 +1184,7 @@ define KernelPackage/usb-net-asix
TITLE:=Kernel module for USB-to-Ethernet Asix convertors
DEPENDS:= \
+kmod-libphy +kmod-net-selftests +kmod-mdio-devres +kmod-phy-ax88796b \
- +LINUX_6_1:kmod-phylink
+ +LINUX_6_1:kmod-phylink +LINUX_6_6:kmod-phylink
KCONFIG:=CONFIG_USB_NET_AX8817X
FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/asix.ko
AUTOLOAD:=$(call AutoProbe,asix)
@@ -1312,7 +1312,7 @@ $(eval $(call KernelPackage,usb-net-smsc75xx))
define KernelPackage/usb-net-smsc95xx
TITLE:=SMSC LAN95XX based USB 2.0 10/100 ethernet devices
- DEPENDS:=+kmod-libphy +kmod-phy-smsc +LINUX_6_1:kmod-net-selftests
+ DEPENDS:=+kmod-libphy +kmod-phy-smsc +!LINUX_5_15:kmod-net-selftests
KCONFIG:=CONFIG_USB_NET_SMSC95XX
FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/smsc95xx.ko
AUTOLOAD:=$(call AutoProbe,smsc95xx)
@@ -1605,7 +1605,7 @@ define KernelPackage/usb-hid-mcp2221
SUBMENU:=$(USB_MENU)
TITLE:=Microchip USB 2.0 to I2C/UART Protocol Converter with GPIO
KCONFIG:=CONFIG_HID_MCP2221
- DEPENDS:=@GPIO_SUPPORT +kmod-usb-hid +kmod-i2c-core
+ DEPENDS:=@GPIO_SUPPORT +kmod-usb-hid +kmod-i2c-core +LINUX_6_6:kmod-iio-core
FILES:=$(LINUX_DIR)/drivers/hid/hid-mcp2221.ko
AUTOLOAD:=$(call AutoProbe,hid-mcp2221)
endef