summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-09-20 13:20:21 +0200
committerJo-Philipp Wich <jo@mein.io>2019-09-20 13:27:28 +0200
commitabb4f4075e791789fdb00731035e08a8cf51555f (patch)
treeb255f9ae5cc85204b4292aab77d37b34b4bedac7 /package
parent4209b28d23b8bf28575af5e8904194f49b81532e (diff)
downloadopenwrt-abb4f4075e791789fdb00731035e08a8cf51555f.tar.gz
openwrt-abb4f4075e791789fdb00731035e08a8cf51555f.tar.bz2
openwrt-abb4f4075e791789fdb00731035e08a8cf51555f.zip
hostapd: mirror ieee80211w ap mode defaults in station mode
For AP mode, OpenWrt automatically sets ieee80211w to either 1 or 2, depending on whether the encryption is set to sae-mixed, or sae/owe/eap suite-b. Mirror the same defaults for client mode connections, in order to allow an OpenWrt station to associate to an OpenWrt ap with SAE, OWE or Suite-B encryption without the need to manually specify "option ieee80211w" on the station. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd.sh9
2 files changed, 10 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index e94d66211d..63e7a5dea1 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=10
+PKG_RELEASE:=11
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/files/hostapd.sh b/package/network/services/hostapd/files/hostapd.sh
index c7f3ea2c1e..8da8539e8a 100644
--- a/package/network/services/hostapd/files/hostapd.sh
+++ b/package/network/services/hostapd/files/hostapd.sh
@@ -747,6 +747,15 @@ wpa_supplicant_add_network() {
ieee80211w ieee80211r \
multi_ap
+ case "$auth_type" in
+ sae|owe|eap192|eap-eap192)
+ set_default ieee80211w 2
+ ;;
+ psk-sae)
+ set_default ieee80211w 1
+ ;;
+ esac
+
set_default ieee80211r 0
set_default multi_ap 0