summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-01-28 21:16:16 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-07-04 20:25:40 +0200
commitd026b19cdcda50766e1ecc350fdc7c542e0f1c73 (patch)
treecd11666a1af9c72519106c663277b53a5643adbd /rules.mk
parentca788d615fbf780b1a1665475ed304de4276f512 (diff)
downloadopenwrt-d026b19cdcda50766e1ecc350fdc7c542e0f1c73.tar.gz
openwrt-d026b19cdcda50766e1ecc350fdc7c542e0f1c73.tar.bz2
openwrt-d026b19cdcda50766e1ecc350fdc7c542e0f1c73.zip
build: replace SSTRIP_ARGS with SSTRIP_DISCARD_TRAILING_ZEROES
sstrip only has one functional arg. Make that a bool option, which can easily depend on other knobs then. This is required to be disabled for the mold linker. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 1cedd91aa8..ca27583d27 100644
--- a/rules.mk
+++ b/rules.mk
@@ -330,7 +330,7 @@ else
STRIP:=$(TARGET_CROSS)strip $(call qstrip,$(CONFIG_STRIP_ARGS))
else
ifneq ($(CONFIG_USE_SSTRIP),)
- STRIP:=$(STAGING_DIR_HOST)/bin/sstrip $(call qstrip,$(CONFIG_SSTRIP_ARGS))
+ STRIP:=$(STAGING_DIR_HOST)/bin/sstrip $(if $(CONFIG_SSTRIP_DISCARD_TRAILING_ZEROES),-z)
endif
endif
RSTRIP= \