summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2023-12-04 21:02:13 +0900
committerHauke Mehrtens <hauke@hauke-m.de>2024-05-25 20:02:59 +0200
commit0618eae50672cb78efaea938a6a4b5eb4712b00e (patch)
treed32e505cc82e02b9fdb933c8ec6b9ed1af03a892 /target/linux/mvebu/image
parentc5b7ec8cee497c3a84eb8ad90d88494f0812698c (diff)
downloadopenwrt-0618eae50672cb78efaea938a6a4b5eb4712b00e.tar.gz
openwrt-0618eae50672cb78efaea938a6a4b5eb4712b00e.tar.bz2
openwrt-0618eae50672cb78efaea938a6a4b5eb4712b00e.zip
mvebu: add common image definition for FortiGate devices
Add a common definition of Fortinet FortiGate devices to image/cortexa9.mk for a preparation of adding support for other FortiGate 3xE/5xE devices. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/cortexa9.mk24
1 files changed, 11 insertions, 13 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index 7c68740e11..a73e3ff5e5 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -114,33 +114,31 @@ define Device/cznic_turris-omnia
endef
TARGET_DEVICES += cznic_turris-omnia
-define Device/fortinet_fg-30e
+define Device/fortinet
DEVICE_VENDOR := Fortinet
- DEVICE_MODEL := FortiGate 30E
SOC := armada-385
KERNEL := kernel-bin | append-dtb
- KERNEL_INITRAMFS := kernel-bin | append-dtb | fortigate-header | \
- gzip-filename FGT30E
KERNEL_SIZE := 6144k
- DEVICE_DTS := armada-385-fortinet-fg-30e
IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | \
sysupgrade-tar rootfs=$$$$@ | append-metadata
DEVICE_PACKAGES := kmod-hwmon-nct7802
endef
+
+define Device/fortinet_fg-30e
+ $(Device/fortinet)
+ DEVICE_MODEL := FortiGate 30E
+ DEVICE_DTS := armada-385-fortinet-fg-30e
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | fortigate-header | \
+ gzip-filename FGT30E
+endef
TARGET_DEVICES += fortinet_fg-30e
define Device/fortinet_fg-50e
- DEVICE_VENDOR := Fortinet
+ $(Device/fortinet)
DEVICE_MODEL := FortiGate 50E
- SOC := armada-385
- KERNEL := kernel-bin | append-dtb
+ DEVICE_DTS := armada-385-fortinet-fg-50e
KERNEL_INITRAMFS := kernel-bin | append-dtb | fortigate-header | \
gzip-filename FGT50E
- KERNEL_SIZE := 6144k
- DEVICE_DTS := armada-385-fortinet-fg-50e
- IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | \
- sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := kmod-hwmon-nct7802
endef
TARGET_DEVICES += fortinet_fg-50e