summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2024-10-05 15:05:50 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2024-10-06 03:46:45 +0200
commit0852d814f0157f780e9309369cf2996fd86b951b (patch)
tree1cc672fc61c293fb1b53238202ee1965b0cef9ee /target
parent685fa051d5608bbb2888a04b6e4474faca093cca (diff)
downloadopenwrt-0852d814f0157f780e9309369cf2996fd86b951b.tar.gz
openwrt-0852d814f0157f780e9309369cf2996fd86b951b.tar.bz2
openwrt-0852d814f0157f780e9309369cf2996fd86b951b.zip
gemini: Use absolute paths for tools
Use the absolute path to access the e2fsprogs applications. It is also working with relative paths, but this makes sure that we use our versions. Link: https://github.com/openwrt/openwrt/pull/16607 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/gemini/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index 3ddb6e5554..819291ef7f 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -55,8 +55,8 @@ define Build/dns313-images
--root $@.tmp $@.tmp-boot
# The device firmware needs revision 1 of EXT2
- tune2fs -O filetype $@.tmp-boot
- e2fsck -pDf $@.tmp-boot > /dev/null
+ $(STAGING_DIR_HOST)/bin/tune2fs -O filetype $@.tmp-boot
+ $(STAGING_DIR_HOST)/bin/e2fsck -pDf $@.tmp-boot > /dev/null
./dns313_gen_hdd_img.sh $@ $@.tmp-boot $(IMAGE_ROOTFS) \
$(CONFIG_TARGET_KERNEL_PARTSIZE) \