summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2023-04-20 01:59:32 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2023-04-20 14:21:46 +0200
commit291b137778eece9edf4b960d4d5c27fc1ce91e06 (patch)
tree35ceb4b3bce85a573fd280a5a8eb5d8d63527afc /tools/Makefile
parent42eeb22450f2c3225fa79a75c0ba881ac6809a77 (diff)
downloadopenwrt-291b137778eece9edf4b960d4d5c27fc1ce91e06.tar.gz
openwrt-291b137778eece9edf4b960d4d5c27fc1ce91e06.tar.bz2
openwrt-291b137778eece9edf4b960d4d5c27fc1ce91e06.zip
tools/lz4: build with meson
Simplifies Makefile and speeds up compilation. Before: Executed in 68.00 secs fish external usr time 104.17 secs 1.33 millis 104.17 secs sys time 4.29 secs 0.35 millis 4.29 secs After: Executed in 27.98 secs fish external usr time 25.18 secs 1.32 millis 25.18 secs sys time 3.31 secs 0.35 millis 3.31 secs Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 722d42b2c2..7e8fbad107 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -104,6 +104,7 @@ $(curdir)/isl/compile := $(curdir)/gmp/compile
$(curdir)/liblzo/compile := $(curdir)/cmake/compile
$(curdir)/libressl/compile := $(curdir)/pkgconf/compile
$(curdir)/libtool/compile := $(curdir)/automake/compile $(curdir)/missing-macros/compile
+$(curdir)/lz4/compile := $(curdir)/meson/compile
$(curdir)/lzma-old/compile := $(curdir)/zlib/compile
$(curdir)/lzop/compile := $(curdir)/cmake/compile $(curdir)/liblzo/compile
$(curdir)/llvm-bpf/compile := $(curdir)/cmake/compile