summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-24 17:11:52 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2022-09-29 19:33:17 +0200
commit89df3589e6237e5ad9b5cdd9f87c82987b200e37 (patch)
treeaf05a4a7bf8399cf873e2d476323fbdb41db7b59 /tools/Makefile
parentd602e7a969922121800e8f24d81cecdaab3aae75 (diff)
downloadopenwrt-89df3589e6237e5ad9b5cdd9f87c82987b200e37.tar.gz
openwrt-89df3589e6237e5ad9b5cdd9f87c82987b200e37.tar.bz2
openwrt-89df3589e6237e5ad9b5cdd9f87c82987b200e37.zip
tools/expat: build with autotools again
Allows to set expat as a dependency to cmake and save on compilation time. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/tools/Makefile b/tools/Makefile
index ae1c3ded85..78fc125ecf 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -22,13 +22,13 @@ ifneq ($(CONFIG_SDK)$(CONFIG_PACKAGE_kmod-b43)$(CONFIG_PACKAGE_b43legacy-firmwar
endif
tools-y += autoconf autoconf-archive automake bc bison cmake cpio dosfstools
-tools-y += e2fsprogs fakeroot findutils firmware-utils flex gengetopt
+tools-y += e2fsprogs expat fakeroot findutils firmware-utils flex gengetopt
tools-y += libressl libtool lzma m4 make-ext4fs meson missing-macros mkimage
tools-y += mklibs mtd-utils mtools ninja padjffs2 patch-image
tools-y += patchelf pkgconf quilt squashfskit4 sstrip zip zlib zstd
tools-$(BUILD_B43_TOOLS) += b43-tools
tools-$(BUILD_ISL) += isl
-tools-$(BUILD_TOOLCHAIN) += expat gmp mpc mpfr
+tools-$(BUILD_TOOLCHAIN) += gmp mpc mpfr
tools-$(CONFIG_TARGET_apm821xx)$(CONFIG_TARGET_gemini) += genext2fs
tools-$(CONFIG_TARGET_ath79) += lzma-old squashfs
tools-$(CONFIG_TARGET_mxs) += elftosb sdimage
@@ -47,7 +47,6 @@ $(curdir)/bison/compile := $(curdir)/flex/compile
$(curdir)/cbootimage/compile += $(curdir)/automake/compile
$(curdir)/cmake/compile += $(curdir)/libressl/compile $(curdir)/ninja/compile
$(curdir)/dosfstools/compile := $(curdir)/autoconf/compile $(curdir)/automake/compile
-$(curdir)/expat/compile := $(curdir)/cmake/compile
$(curdir)/e2fsprogs/compile := $(curdir)/libtool/compile
$(curdir)/fakeroot/compile := $(curdir)/libtool/compile
$(curdir)/findutils/compile := $(curdir)/bison/compile