summaryrefslogtreecommitdiffstats
path: root/tools/flex
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-28 01:23:56 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2022-10-20 00:33:22 +0200
commita63805b25f99e609d575ee920baae269fb58794c (patch)
tree3d7090484571e2b300efdd658033378c250a485e /tools/flex
parentf2ae4e2f8cf698f6fc6ae802dae86f50916f4286 (diff)
downloadopenwrt-a63805b25f99e609d575ee920baae269fb58794c.tar.gz
openwrt-a63805b25f99e609d575ee920baae269fb58794c.tar.bz2
openwrt-a63805b25f99e609d575ee920baae269fb58794c.zip
tools: add Host/Uninstall where possible
This cleans staging_dir when calling tool/x/clean. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/flex')
-rw-r--r--tools/flex/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/tools/flex/Makefile b/tools/flex/Makefile
index bb5aecbdfe..da037ae72d 100644
--- a/tools/flex/Makefile
+++ b/tools/flex/Makefile
@@ -26,8 +26,12 @@ define Host/Install
$(LN) flex $(STAGING_DIR_HOST)/bin/lex
endef
+define Host/Uninstall
+ -$(call Host/Compile/Default,uninstall)
+endef
+
define Host/Clean
- -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ rm -f $(STAGING_DIR_HOST)/bin/lex
$(call Host/Clean/Default)
endef