summaryrefslogtreecommitdiffstats
path: root/tools/flex
diff options
context:
space:
mode:
Diffstat (limited to 'tools/flex')
-rw-r--r--tools/flex/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/tools/flex/Makefile b/tools/flex/Makefile
index bb5aecbdfe..da037ae72d 100644
--- a/tools/flex/Makefile
+++ b/tools/flex/Makefile
@@ -26,8 +26,12 @@ define Host/Install
$(LN) flex $(STAGING_DIR_HOST)/bin/lex
endef
+define Host/Uninstall
+ -$(call Host/Compile/Default,uninstall)
+endef
+
define Host/Clean
- -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ rm -f $(STAGING_DIR_HOST)/bin/lex
$(call Host/Clean/Default)
endef