summaryrefslogtreecommitdiffstats
path: root/tools/gnulib
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2023-01-11 18:41:22 +0100
committerFelix Fietkau <nbd@nbd.name>2023-10-29 15:56:46 +0100
commit5331e85d96346be4200ce206b2f4373e23af0f6f (patch)
treee1a4287a6e836c11b13be8fbbd739561be3929c1 /tools/gnulib
parent169757c7fd483787fb910c9d7b366fcd91ead49f (diff)
downloadopenwrt-5331e85d96346be4200ce206b2f4373e23af0f6f.tar.gz
openwrt-5331e85d96346be4200ce206b2f4373e23af0f6f.tar.bz2
openwrt-5331e85d96346be4200ce206b2f4373e23af0f6f.zip
elfutils: fix build and enable on non-linux systems
Use gnulib for compatibility Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/gnulib')
-rw-r--r--tools/gnulib/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/gnulib/Makefile b/tools/gnulib/Makefile
index 43d86c213c..2ce763f6ab 100644
--- a/tools/gnulib/Makefile
+++ b/tools/gnulib/Makefile
@@ -18,10 +18,11 @@ define Host/Install
$(INSTALL_DATA) $(HOST_BUILD_DIR)/m4/*.m4 $(1)/share/aclocal/
$(INSTALL_DIR) $(1)/share/gnulib
$(CP) $(HOST_BUILD_DIR)/* $(1)/share/gnulib/
+ ln -sf ../share/gnulib/gnulib-tool $(STAGING_DIR_HOST)/bin/gnulib-tool
endef
define Host/Clean
- rm -rf $(STAGING_DIR_HOST)/share/gnulib
+ rm -rf $(STAGING_DIR_HOST)/bin/gnulib-tool $(STAGING_DIR_HOST)/share/gnulib
endef
$(eval $(call HostBuild))