summaryrefslogtreecommitdiffstats
path: root/tools/meson
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-10-24 11:10:26 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2021-10-30 21:17:20 +0200
commit3bd31cc4d2ff02c2d3c3db80ade7badab08f3e93 (patch)
tree35ade9fe5149572f49361cae4faa872c4d82f28d /tools/meson
parent02026d0a6f2e4b939178219a703158cd7b9d658a (diff)
downloadopenwrt-3bd31cc4d2ff02c2d3c3db80ade7badab08f3e93.tar.gz
openwrt-3bd31cc4d2ff02c2d3c3db80ade7badab08f3e93.tar.bz2
openwrt-3bd31cc4d2ff02c2d3c3db80ade7badab08f3e93.zip
tools/meson: update to 0.60.0
Add cmake support to meson. Otherwise only pkgconfig can be used. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/meson')
-rw-r--r--tools/meson/Makefile4
-rw-r--r--tools/meson/files/openwrt-cross.txt.in1
-rw-r--r--tools/meson/files/openwrt-native.txt.in1
3 files changed, 4 insertions, 2 deletions
diff --git a/tools/meson/Makefile b/tools/meson/Makefile
index 1aab5d8fcb..f648085f90 100644
--- a/tools/meson/Makefile
+++ b/tools/meson/Makefile
@@ -1,11 +1,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=meson
-PKG_VERSION:=0.59.2
+PKG_VERSION:=0.60.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/mesonbuild/meson/releases/download/$(PKG_VERSION)
-PKG_HASH:=13dee549a7ba758b7e33ce7719f28d1d337a98d10d378a4779ccc996f5a2fc49
+PKG_HASH:=080d68b685e9a0d9c9bb475457e097b49e1d1a6f750abc971428a8d2e1b12d47
PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
PKG_LICENSE:=Apache-2.0
diff --git a/tools/meson/files/openwrt-cross.txt.in b/tools/meson/files/openwrt-cross.txt.in
index 30b4c116c4..56aa393d63 100644
--- a/tools/meson/files/openwrt-cross.txt.in
+++ b/tools/meson/files/openwrt-cross.txt.in
@@ -5,6 +5,7 @@ ar = '@AR@'
strip = '@STRIP@'
nm = '@NM@'
pkgconfig = '@PKGCONFIG@'
+cmake = '@CMAKE@'
[built-in options]
c_args = [@CFLAGS@]
diff --git a/tools/meson/files/openwrt-native.txt.in b/tools/meson/files/openwrt-native.txt.in
index 50308ec8e4..eba63c00b1 100644
--- a/tools/meson/files/openwrt-native.txt.in
+++ b/tools/meson/files/openwrt-native.txt.in
@@ -2,6 +2,7 @@
c = [@CC@]
cpp = [@CXX@]
pkgconfig = '@PKGCONFIG@'
+cmake = '@CMAKE@'
[built-in options]
c_args = [@CFLAGS@]