summaryrefslogtreecommitdiffstats
path: root/tools/meson
diff options
context:
space:
mode:
Diffstat (limited to 'tools/meson')
-rw-r--r--tools/meson/Makefile4
-rw-r--r--tools/meson/files/openwrt-cross.txt.in1
-rw-r--r--tools/meson/files/openwrt-native.txt.in1
3 files changed, 4 insertions, 2 deletions
diff --git a/tools/meson/Makefile b/tools/meson/Makefile
index 1aab5d8fcb..f648085f90 100644
--- a/tools/meson/Makefile
+++ b/tools/meson/Makefile
@@ -1,11 +1,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=meson
-PKG_VERSION:=0.59.2
+PKG_VERSION:=0.60.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/mesonbuild/meson/releases/download/$(PKG_VERSION)
-PKG_HASH:=13dee549a7ba758b7e33ce7719f28d1d337a98d10d378a4779ccc996f5a2fc49
+PKG_HASH:=080d68b685e9a0d9c9bb475457e097b49e1d1a6f750abc971428a8d2e1b12d47
PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
PKG_LICENSE:=Apache-2.0
diff --git a/tools/meson/files/openwrt-cross.txt.in b/tools/meson/files/openwrt-cross.txt.in
index 30b4c116c4..56aa393d63 100644
--- a/tools/meson/files/openwrt-cross.txt.in
+++ b/tools/meson/files/openwrt-cross.txt.in
@@ -5,6 +5,7 @@ ar = '@AR@'
strip = '@STRIP@'
nm = '@NM@'
pkgconfig = '@PKGCONFIG@'
+cmake = '@CMAKE@'
[built-in options]
c_args = [@CFLAGS@]
diff --git a/tools/meson/files/openwrt-native.txt.in b/tools/meson/files/openwrt-native.txt.in
index 50308ec8e4..eba63c00b1 100644
--- a/tools/meson/files/openwrt-native.txt.in
+++ b/tools/meson/files/openwrt-native.txt.in
@@ -2,6 +2,7 @@
c = [@CC@]
cpp = [@CXX@]
pkgconfig = '@PKGCONFIG@'
+cmake = '@CMAKE@'
[built-in options]
c_args = [@CFLAGS@]