summaryrefslogtreecommitdiffstats
path: root/tools/mpc
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2022-12-02 20:13:06 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-01-09 21:33:19 +0100
commite854dcaef37cdb59109448889e9da9358591748a (patch)
treec8e56e258bb316f29a8e852c663fff2e4ea5987e /tools/mpc
parent7b56ca399a539600090f1710f9225f706dd5b2eb (diff)
downloadopenwrt-e854dcaef37cdb59109448889e9da9358591748a.tar.gz
openwrt-e854dcaef37cdb59109448889e9da9358591748a.tar.bz2
openwrt-e854dcaef37cdb59109448889e9da9358591748a.zip
tools/mpc: use STAGING_DIR_HOST instead of hardcoding default
Use STAGING_DIR_HOST to reference the staging dir for host tools instead of hardcoding it to the default location. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'tools/mpc')
-rw-r--r--tools/mpc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/mpc/Makefile b/tools/mpc/Makefile
index 5c196a27ef..97e94291cb 100644
--- a/tools/mpc/Makefile
+++ b/tools/mpc/Makefile
@@ -22,8 +22,8 @@ unexport CFLAGS
HOST_CONFIGURE_ARGS += \
--enable-static \
--disable-shared \
- --with-mpfr=$(TOPDIR)/staging_dir/host \
- --with-gmp=$(TOPDIR)/staging_dir/host
+ --with-mpfr=$(STAGING_DIR_HOST) \
+ --with-gmp=$(STAGING_DIR_HOST)
define Host/Uninstall
-$(call Host/Compile/Default,uninstall)