summaryrefslogtreecommitdiffstats
path: root/tools/quilt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-07-31 17:59:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-07-31 17:59:35 +0000
commit5ee5f0d314f656328f4f419438c0b62fcbcef9a6 (patch)
treee0ef1740d671474f76eac2118d7e08c574107980 /tools/quilt
parentfa9521ad91bd1e927ccee6478a00bdd6c68c0367 (diff)
downloadopenwrt-5ee5f0d314f656328f4f419438c0b62fcbcef9a6.tar.gz
openwrt-5ee5f0d314f656328f4f419438c0b62fcbcef9a6.tar.bz2
openwrt-5ee5f0d314f656328f4f419438c0b62fcbcef9a6.zip
quilt: make it possible to override the path to getopt (based on patch from #9842)
SVN-Revision: 27852
Diffstat (limited to 'tools/quilt')
-rw-r--r--tools/quilt/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/quilt/Makefile b/tools/quilt/Makefile
index 0ed5d064b5..510d8f6fd5 100644
--- a/tools/quilt/Makefile
+++ b/tools/quilt/Makefile
@@ -15,9 +15,12 @@ PKG_MD5SUM:=f77adda60039ffa753f3c584a286f12b
include $(INCLUDE_DIR)/host-build.mk
+GETOPT:=$(shell which getopt)
+
HOST_CONFIGURE_ARGS += \
--with-patch=$(PATCH) \
- --with-find=$(FIND)
+ --with-find=$(FIND) \
+ --with-getopt=$(GETOPT)
define Host/Configure
cd $(HOST_BUILD_DIR) && autoconf