summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--rules.mk8
-rw-r--r--toolchain/gcc/Config.in5
-rw-r--r--toolchain/gcc/Config.version5
3 files changed, 9 insertions, 9 deletions
diff --git a/rules.mk b/rules.mk
index f1ca735f2e..fbf42f725d 100644
--- a/rules.mk
+++ b/rules.mk
@@ -140,11 +140,11 @@ else
TOOLCHAIN_DIR_NAME:=toolchain-$(GNU_TARGET_NAME)
endif
-ifeq ($(or $(CONFIG_EXTERNAL_TOOLCHAIN),$(CONFIG_GCC_VERSION_4_8),$(CONFIG_TARGET_uml)),)
- ifeq ($(CONFIG_GCC_USE_EMBEDDED_PATH_REMAP),y)
- iremap = -fmacro-prefix-map=$(1)=$(2)
- else
+ifeq ($(or $(CONFIG_EXTERNAL_TOOLCHAIN),$(CONFIG_TARGET_uml)),)
+ ifeq ($(CONFIG_GCC_USE_IREMAP),y)
iremap = -iremap$(1):$(2)
+ else
+ iremap = -ffile-prefix-map=$(1)=$(2)
endif
endif
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 0977f9b4e7..2c592a904b 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -22,6 +22,11 @@ choice
bool "gcc 9.x"
endchoice
+config GCC_USE_IREMAP
+ default y if ( GCC_USE_VERSION_5 || GCC_USE_VERSION_7 )
+ default n
+ bool
+
config GCC_USE_GRAPHITE
bool
prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index d9732b3e0d..fd8d3873fa 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -11,11 +11,6 @@ config GCC_VERSION_9
default y if GCC_USE_VERSION_9
bool
-config GCC_USE_EMBEDDED_PATH_REMAP
- default y if ( GCC_VERSION_8 || GCC_VERSION_9 )
- default n
- bool
-
config GCC_VERSION
string
default "5.5.0" if GCC_VERSION_5